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Subsurface ventilation specialists LeakyDuct™ 

To install LeakyDuct™ or HotWork™ 
If errors are found in this software, or you have suggestions for improvement, please contact MVA at 

mvamail@mvaust.com.au, with the version number and serial/activation number and the details of the problem 

or suggestion. We will respond to you promptly. 

HotWork and LeakyDuct are Excel-based workbooks (requires Excel 2000 or later) that use a number of 

individual worksheets for the various program features. There is an extensive amount of VisualBasic™ code 

supporting these workbooks. HotWork also uses the Excel linear programming Add-in called “Solver”. Sheets 

can be accessed by clicking on the relevant „tab‟ at the bottom of the page. 

Instructions on this page are for Excel 2003. For Excel 2007, see the final page. 

Some help for the user is provided in text boxes on some sheets. Other help can be found in the Cell comments 

which are provided in any spreadsheet cell that has a red corner. To print all of the cell comments on any sheet, 
select File:Page Setup:Sheet:Comments and select "End of sheet", then print. Each sheet will be printed, 

followed by all notes on that sheet. 

To get the software operational: 

1. Copy the LeakyDuct.xls or HotWork.xls file into a new folder on your hard drive 

2. Open Excel first 

3. From the menu bar, select Tools:Macros:Security menu, ensure macro security is set at medium or low 

4. Open the file: HotWork (or LeakyDuct) (if macro security warning comes up, select “enable macros”) 

5. Enter your activation code, your name and organisation, etc when requested 

6. Check the software is operating correctly as follows: 

HotWork 

Select the “TWL” sheet tab 

Change any input value on this sheet. 

Select the yellow “Solve TWL” button. 

If an error messages appears (e.g. one of those below), 

then under the “Tools” menu, select “Add-ins” and then 

de-select “Solver”. Click “OK. Then under “Tools” menu 

again, select “Add-ins” and then re-select the “Solver” 

add-in. Try the Solve TWL button again. (See last page 

for Excel 2007 instructions) 

A valid solution is shown in Figure 1. 

LeakyDuct 

Select the “Simulator” sheet tab 

Change any input value on this sheet. 

Select the yellow “Calculate” button. 

A valid solution is shown in Figure 2. 

  

7. If the program stops responding (calculating), check: 

 Tools:Options:Calculation and that “automatic” is selected and that “Iteration” is selected along with 

“Maximum iterations” of 1000 and “Maximum change” of 0.000001. [In Excel 2007, use Office 

Button>Excel Options> Formulas>Calculation Options] 

 Data:Macro:Macros then select “ControlledExit” and then “Run” [In Excel 2007, use 

Developer>Macros] (To show the Developer tab, use Office Button>Excel Options>Popular>Show 

Developer Tab) 

8. If you have any further problems getting the software operational, contact MVA 

9. Save the activated version of HotWork or LeakyDuct into a folder on your hard drive) 

Note that each copy of LeakyDuct or HotWork is licensed for use on only one PC. 

Note that LeakyDuct comes with a worked example as a pdf file. Contact MVA if you do not have this worked 

example.
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Figure 1 

Parameter Value Units Low limit High limit Parameter Value Units Parameter Value Units Parameter Value Units 253 TWL in HSM

Barometric Pressure 101.0 kPa 80 120 Rel Wind speed 2.5 m/s Convect'n+Rad'n -42 W/m
2 Sweat rate 1.16 kg/hr #NAME?

Wet bulb T 25.0 deg C 20 32 Mean Radiant T 49.1 deg C Evap from skin 301 W/m
2 Tskin 35.07 deg C 295 Howes

Dry bulb T 36.0 deg C 20 45 Relative Hum 41% % Respiration 15 W/m
2 Tcore 38.20 deg C 324 ACGIH

Wind speed 2.50 m/s 0.2 4 Dew Point T 20.8 deg C Qcoretoskin 259 W/m
2 TWLconstrained 275 W/m

2 194 ISO

Globe T 39.0 deg C 20 75 hr 5.2 W/(m
2
.K) Qskintoenv 259 W/m

2 TWLunconstrained 274 W/m
2

Latent Heat Sweat 2 430 kJ/kg 2400 2750 hc 16.8 W/(m
2
.K) Psatskin 5.64 kPa Tcunconstrained 38.20 deg C 35.64 Nude

Icl, clothing conduct. 0.35 clo 0 1 h 22.0 W/(m
2
.K) Pair 2.45 kPa Srunconstrained 1.16 kg/hr 35.29 Clothed

icl, vapour perm ratio 0.45 d'less 0.1 1 he 277.3 W/(m
2
.K) K, conductance 82.74 W/(m

2
.K) TRUE

litre/hr 0.00 1.20 toper 39.08 deg C Dripping sweat 0.71 kg/hr 36161.0000

deg C 37.00 38.20 fcl 1.105 d'less Sweat efficiency 38% d'less 3

deg C 25.00 38.20 Rcl 0.05425 m
2
.K/W Emax, actual 301 W/m

2 Graham Bates

deg C 35.00 39.50 Fcl 0.43157 d'less Emax, if nude 883 W/m
3

fraction 0.00 1.00 Fcle 0.47689 d'less Sr/Emax 2.60 d'less

W/m
2 80 800 Recl 0.00731 m

2
.kPa/W Evaporation rate 301 W/m

2

Fpcl 0.309 d'less Tsigma 37.89 deg C

im 0.547 d'less Wettedness 1.00 d'less

Thermal Work Limit Model Copyright MVA, 2000-2004. All rights reserved.
Note: The author and the supplier have no liability to the licensee or any other person or entity for any damage or loss, including special, incidental or consequential damages caused by this product directly or indirectly. This software is 

provided "as is" without warranty of any kind, either expressed or implied. Warranties of merchantability or of fitness for any purpose are specifically excluded.

Warning: Uncalculated data!

OUTPUTS

Thermoregulatory signal, Tsigma

Sweat rate

Deep body core temp

Mean skin temp

INTERMEDIATE & SUPPLEMENTARY CALCULATIONSINPUTS & CONSTRAINTS

Skin wettedness

Metabolic rate

INSTRUCTIONS:  Only change values in BLUE. Values in PURPLE can be 

changed if using model for other purposes.

The standard TWL values for summer, cotton work uniform, including long 

trousers, T-shirt, hard hat and safety boots are: Icl=0.35,  icl=0.45, Tc=38.2
0
, 

Sr=1.2 kg/hr, Met Rate max = 800 W/m
2
 and skin wetness max = 1.0. Assumes 

wet clothing due to excess of sweat at limiting met rate. This may not be true 

where the efficiency of sweating is high and little sweat drips. For typical dry 

summer work uniform  Icl=0.55 (see Data sheet). Program will endeavour to 

highlight situations where a solution is not valid and will issue warnings and 

highlight "problem" cells. Typical problems include impossible input data (e.g. 

DB<WB) or constraints that do not allow a solution within the range of 

physiological relationships used to define TWL. Program will also highlight 

which constraint is the limiting constraint. 'Unconstrained' values is an 

acceptable solution to the model with fully wet skin, and Tc>=38.2. Note: this 

model does not automatically limit WB, DB and wind speed to 32 deg, 45 deg 

and 4 m/s respectively, as recommended in the technical paper. However, cells 

failing these criteria are highlighted.

Solve 

TWL

Model can be used in several modes:

1. To predict limiting met rate (TWL) at maximum (or specific) Tc and Sr. To use a specific Tc or 

Sr, set the high and low limits to a very narrow value. Note that this will usually mean relaxing 

another constraint as well (e.g. if Tc is fixed at more than 38.2deg, then Sr may need to be relaxed 

to 1.5 l/hr, etc)

2. To predict Tc and Sr at a fixed met rate(TWL). To do this, set Metabolic rate to a very narrow 

value. Again, this may require both Tc and Sr to be relaxed.

3. To iteratively find the WB (or DB or wind etc) for a given met rate (TWL) and Tc/Sr.

For further comments, hold mouse over any cell with a red flag in its corner.

For recommended TWL limits refer to attached sheet.

 
Figure 2 

Fan Total Pressure Pa 1 081

Duct Length m  200 Fan Static Pressure (FSP) Pa  987

Length with shock losses m  250 Fan Airflow per duct m
3
/s 10.7

Air density kg/m
3 1.200 Fan Resistance at 1.2 kg/m

3
Ns

2
/m

8 8.6

Duct (NOT fan) diameter) m 0.91 Airflow out of/into duct m
3
/s 8.1

K factor of duct at 1.2 kg/m3 0.00350 Leakage/fan Q % 24%

Ns
2
/m

4 0.0040 Leakage per duct m
3
/s 2.6

Duct leakage factor 239 Leakage/Face flow % 32%

OR manual entry mm
2
 leakage area per m

2
 area (including effects of duct joins, etc) 100 Duct velocity pressure Pa, %FTP 93, 9%

Maximum FSP this fan Pa 2 431

Type of fan Fan free-delivery flow per duct m
3
/s 11.0

Electrical power cost $/(kW.hr) 0.08$     Fan Q as % of Qmax % 97%

Approx fan efficiency % based on FSP, assumed constant 70% FSP as % of FSPmax % 41%

Approx elec cost $/day/duct $/day/duct 15.36

-16.99 Approx cost/(m
3
/s) cents/(m

3
/s) 0.08

749.75

992.76 Distance from fan m 50

38.5 Nett return this point/duct m
3
/s 9.6

22.5 Duct static pressure this pt Pa 555

Parabola A constant (from FTP curve, NOT FSP curve constants)

    LeakySimTM   Copyright MVA 2000-2006. All rights reserved. Enter data in blue only. NOTE: RED values indicate warnings or bad data or invalid/poor results

1. Assumes forcing or exhausting fan or fan combination at end of duct. Fan can be a series, parallel or "Y" combination (fan feeding twin ducts).

2. Assumes air density is constant (compressibility ignored), leakage is influenced by static pressure across duct wall only, duct is of uniform diameter and quality (K and leakage factors are constant along duct [although 

friction losses and leakage itself are NOT constant]), and velocity pressure at duct outlet (forcing fans) or duct inlet (exhausting fans) is small compared to fan total pressure.

3. When leakage exceeds 85% of fan airflow, result is unreliable.

4. Whilst very unlikely in most circumstances, the pressure loss to push the air back out of the heading may be significant on rare occasions and should be checked.

5. Note that a more powerful fan or lower leakage factor may not improve a solution, e.g. a lower leakage factor will increase the fan pressure perhaps to a point beyond the fan's pressure capability (i.e. goes into stall), and a 

more powerful fan may have its surge point (min flow value) at a flow that is too high for the duct (i.e. it also goes into stall), etc. In both cases, the 'commonsense' solutions to improve the fan or duct performance may result in 

producing no solution at all.

6. To find the airflow returning from the face at any point in the auxiliary compartment, use the "Predicted return air flow outside duct". This is helpful in determining how far diesels can go in a heading.

7. It is strongly recommended that you use real fan data and real duct friction, leakage and shock loss factors for any simulation.

Also you should consider a range of values (i.e. look at the sensitivity of the solution to different fan and duct characteristics) before making a final selection.

DUCT INPUT DATA

OR (instead of providing known fan type, provide fan curve constants)

FAN INPUT DATA

INPUTS OUTPUTS (per duct)

Parabola B constant (from FTP curve, NOT FSP curve constants)

Parabola C constant (from FTP curve, NOT FSP curve constants)

Predicted return air flow outside duct

Maximum Q on curve, cms, (optional)

Minimum Q on curve, cms (optional)

Calculate

Solution strategy:
Fan component:
The "seed" value is the initial guess of the flow out of the end of the duct (forcing fan).
The FTP is calculated from this value using the fan constants.
FVP is calculated from the seed value and the velocity pressure going into the duct (out of the fan)
FSP is calculated as FTP - FVP.
Duct component:
Tmodel, Rdmodel, Rl model, PIRmodel and VIR model are all calculated from duct parameters
Qductinlet and Pfduct are calculated from Qseed and VIR and PIR.
For a valid solution the FSP must equal Pfduct and Qseed is iterated to find the value that achieves this.

ESN7-300 (30 kW, 700 dia)

Flexible vent bag - fair (service) condition - 0.00350

Flexible vent bag, 20 m lengths, typical - 239
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Printing comments in Excel 2007 
If your worksheet contains comments, you can print them as they appear on the sheet or at the end of the sheet. 
1. Click the worksheet that contains the comments that you want to print.  
2. To print the comments in place on the worksheet, display them by doing one of the following:  

 To display an individual comment, click the cell that contains the comment, and then on 
the Review tab, in the Comments group, click Show/Hide Comment.  
 TIP   You can also right-click the cell and then click Show/Hide Comments on the shortcut menu. 

 To display all comments, on the Review tab, in the Comments group, click Show All 
Comments.  

 
 TIP   You can move and resize any overlapping comments. 

How to move or resize comments 
1. Click the border of the comment box so that handles appear:  

 
2. Do one or both of the following:  

 To move the comment, drag the border of the comment box.  

 To change the size, drag the handles on the sides and corners 
of the comment box. 

3. On the Page Layout tab, in the Page Setup group, click the dialog box launcher next to Page 
Setup.  

 
4. On the Sheet tab, in the Comments box, click As displayed on sheet or At end of sheet.  
5. Click Print.  

 TIP   To see how comments are printed, you can click Print Preview before you click Print. 
 
Enabling macros in Excel 2007 
If the Excel 2007 “Trust Center” detects what it considers to be a security problem with a macro, the macro is 
disabled by default, and the Message Bar appears to notify you of a potentially unsafe macro. 

 
If you click Options on the Message Bar, a security dialog box opens, giving you the option to enable the macro. 
See the next section for how to make a secure decision before you click an option. 
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